Thread Verfasser: Chris1278
Thread ID: 1531
Thread Info
Es gibt 11 Beiträge zu diesem Thema, und es wurde 354 Mal angesehen.
 Thema drucken
php fusion und phpbb forum verbinden
Chris1278
Also kurz zum thema. ich bearbeite für jemandem ne wegseite wo derjenige php fusion (meines wissens version 7 die werd ich aber auf 9 updaten) und ein forum von PHPBB.de

Hierbei handelt es sich um zwei verschiedene logins. ist es möglich das der fusion die user db des forums oder andersrum nutzt. ziel wäre es das man ein login hinbekommt für beides.
 
Systemweb
Fusion authentifiziert per Cookie, PHPBB arbeitet mit Sessions.
Die Passwort-Verschlüsselung ist unterschiedlich.
Ohne massiven Umbau beider Systeme wirst du keine wirklich brauchbare Lösung erzielen, da du 2 Accounts zusammenführen müsstest. Änderungen der Profildaten müssten dann zeitgleich in beiden Systemen übernommen werden.
Bei Neuregistrierungen müsste auch das neue Konto bei beiden angelegt werden.
Eine Notlösung wäre, dass der Fusion-Benutzer im Profil seinen Foren-Account abspeichern könnte und so von der HP kommend auf dem Weg zum Forum autom. eingeloggt wird.
Letztlich wäre zu überlegen, ob der Aufwand es wert ist und man nicht besser einfach das fusioninterne Forum nutzt.
 
Andydeluxe97
Hallo,

Zitat: @Chris1278 Bitte Trage deine richtig webseite ein & nicht "https://keine"


Gruss Andy
 
Chris1278
das könnt ich machen wenn ich eine hätte. Da ichg aber nur für denjenigen hier frage weil ich mich etwas drum kümmere solange er imkrankenhaus ist.
 
Septron
Zitat: Andydeluxe97 schrieb:

Hallo,

Zitat: @Chris1278 Bitte Trage deine richtig webseite ein & nicht "https://keine"


Gruss Andy


Hallo @Andydeluxe97,

bitte unterlasse solche Aufforderungs Kommentare in den Beiträgen dies ist mir schon häufiger aufgefallen wenn es was sinnvolles ist zum Support dann kannst du gerne was dabei schreiben.

In Diesem Sinne schönen Wochenstart Smile
Rechtschreibfehler und Fehlende Satzzeichen sind eine Sünde meiner
Gedanklichen Tastatur wer alle findet darf sie behalten.
Domain Owner of: SGI Fusion | PHPFusion-SupportClub | PHPFusion Germany
 
Chris1278
So noch ne anderer Frage ich habe jetzt local fast erfolgreich das update von 7 auf 9 gemacht wo das schon ne herrausforderung war. aber mal kurz schrit für schritt.

Erst hab ich versucht das 7er system von demjenigen aufs lokale system am laufen zu bringen was ich auch soweit geschaft hatte. nach dem ich dann die ip adresse übder die datebnbank in host umbenannt habe lief es auch mit dem login weil vorher leider nicht ging. nach einlogen wollte ich adminbereich wurde wieder ausgeloggt beim versuch. nach lesen in dem forum hier kam ich dann auf diese lösung.

Dann hab ich das 7 originak paket von der co.uk hp geladen und die anderen files (nicht die datenbank und config.php) gelöscht und durch die original 7er hp ersetzt. Login nicht mehr möglich :-( obwohl ja eigentlich die selbe version sein müsste. wie anfangs schon erwähnt php-fusion mir selber unbekannt bis dato.

So nu mal zu seinem system : er hat V7.02.07 - DE (UPDATE: V1.3)

Nach dem ich dann mit ach und krach das ursprungssystem laufen hatte hab ich das update mit der 9er gemacht lief upgrade soweit durch aber dann kann ich mich nicht mehr einloggen.
 
Layzee
1. Die 7er Version von der co-uk-Page ist NICHT die Gleiche wie das hier erhältliche Update Pack 1.3!
2. Ich empfehle aus verschiedenen Gründen, definitiv bei der V7 zu bleiben (Update Pack)
 
Chris1278
Zitat: Layzee schrieb:

1. Die 7er Version von der co-uk-Page ist NICHT die Gleiche wie das hier erhältliche Update Pack 1.3!
2. Ich empfehle aus verschiedenen Gründen, definitiv bei der V7 zu bleiben (Update Pack)


Dann würd ich dich einfach an dieser Stelle mal zwei fragen stellen wollen.

Zu 1. Was ist an der hier erhältlichen und der auf co.uk anders?


Zu2. Bitte Begründe das mal warum du das empfehlen würdest.
 
Septron
Hallo,

kurz und knapp oben mit der Maus mal ober die Downloads Hovern und PHP-Fusion Core anklicken
und die Unterschiede betrachten, die UK Version ist nichts anderes so wie hier die Standard Version (nur mit Deutschen Sprachdateien dabei)

- Die v9 ist nicht vernünftig Update reif
- DBs die Importiert werden möchten müssen genau angepasst werden Tabelle für Tabelle
- Einige Bereiche sind nicht Sauber geschlossen in gewissen Codes (heißt einige Bereiche sehen sehr Zerschossen aus)
- so gut wie keine Addons
- so gut wie keine Templates
- so Gut wie keine aus dem Deutschen Raume die was Anpassen wollen aufgrund der oben genannten Punkte

Des weiteren macht es kein Sinn eine PHP-Fusion Seite zu Installieren und ein zweites externes Forum System einzubauen obwohl in Fusion ein Funktionierendes System vorhanden ist.

lg
Rechtschreibfehler und Fehlende Satzzeichen sind eine Sünde meiner
Gedanklichen Tastatur wer alle findet darf sie behalten.
Domain Owner of: SGI Fusion | PHPFusion-SupportClub | PHPFusion Germany
 
Systemweb
Zitat: Zu 1. Was ist an der hier erhältlichen und der auf co.uk anders?
Die Version auf der engl. Seite ist die offiziell veröffentlichte aus dem Jahr 2011 und seither nicht mehr aktualisiert worden. Auf Webspace mit PHP-Version höher als 5.5 läuft diese nur noch mit Einschränkungen (PHP 5.6) oder sogar überhaupt nicht mehr (ab PHP 7.0).

Zitat: 2. Ich empfehle aus verschiedenen Gründen, definitiv bei der V7 zu bleiben (Update Pack)
Die originale v7 kannst du nicht mehr verwenden auf Grund der in Punkt 1 genannten Gründe. Die v9 wird als Final bezeichnet, ist aber nach wie vor in Entwicklung und weist noch verschiedene Fehlfunktionen auf. Da wären z.B. Fehler in den Permalinks ("Seite nicht gefunden") oder in den Formularfunktionen in Verbindung mit dem Defender (Token-Fehler beim Absenden von Formularen usw.).
Weiterer Grund: Für v9 gibt es kaum verwendbare Infusionen, da die Entwickler sich mit dem neuen System und den eingebrachten Änderungen nicht anfreunden wollen.

Das sind die Gründe, warum zum aktuellen Zeitpunkt weder die Original v7 noch die Original v9 empfohlen werden kann.
Das von Layzee empfohlene Update-Pack ist die überarbeitete Variante der stabilen v7, wobei alle veralteten Code-Segmente durch neue Schreibweisen ausgetauscht wurden. Dieses Paket ist mit aktuellen PHP-Versionen einsetzbar und du kannst viele der alten bekannten Infusionen damit noch verwenden.
 
Chris1278
Zitat: Septron schrieb:

Des weiteren macht es kein Sinn eine PHP-Fusion Seite zu Installieren und ein zweites externes Forum System einzubauen obwohl in Fusion ein Funktionierendes System vorhanden ist.




JA das verstehe ich aber da nicht meine Seite ist und ich da nur betreuend eigentlich wegen des Forums bin mus der sich selber Entscheiden.



Und dann ist Ok dann macht es wirklich keinen Sinn auf das 9er zu updaten. wenn das wirklich so scheise ist.
 
Springe ins Forum: