Thread Verfasser: speedfire
Thread ID: 1654
Thread Info
Es gibt 2 Beiträge zu diesem Thema, und es wurde 126 Mal angesehen.
 Thema drucken
Hilfe Ubuntu 16.04 6 64Bit mit PHP 5
speedfire
Hallo,

ich bin am verzweifeln.

Meine PHPFusion Homepage v7.02.07 lief bis jetzt auf Ubuntu LTS 12.04 mit PHP 5.3X.

Da es mittlerweile mit SSL Verschlüsselung und Ubuntu und Plesk probleme gegeben hat, hab ich den vserver auf Ubuntu 16.04 64Bit installiert.

Zusätzlich hab ich zum vorhandenen PHP 7.2.21, 7.0.33 auch PHP 5.3.18 installiert. Brauch es noch für Scripte.
PHP 5.3 hab ich nach dieser Anleitung extra drauf installiert:
https://support.plesk.com/hc/en-us/articles/115000497853-How-to-add-a-custom-PHP-version-

Normalerweise müsste ja die Homepage wieder laufen. PHP 5.3.18 ging die Installation Problemlos ohne Fehler durch und konnte mit Plesk auf diese stellen. Scripte würden auch laufen aber PHP Fusion nicht.

Wenn ich PHP 7.2.21 laufen lasse ohne inoffizieles Update kommt diese Fehlermeldung:
Fehlermeldung kommt aber:

Code 

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/vhosts/8157267.online-server.cloud/httpdocs/maincore.php:280 Stack trace: #0 /var/www/vhosts/8157267.online-server.cloud/httpdocs/maincore.php(74): dbconnect('localhost', 'benutzername', 'passwort', 'Datenbankname') #1 /var/www/vhosts/8157267.online-server.cloud/httpdocs/index.php(18): require_once('/var/www/vhosts...') #2 {main} thrown in /var/www/vhosts/8157267.online-server.cloud/httpdocs/maincore.php on line 280




Wenn ich auf 7.0.33, 7.1.31 oder mein 5.3.18 stelle kommt eine leere Seite ohne Fehlermeldungen auch in der Log finde ich kein Eintrag. Anscheinend ist MYSQL nicht erreichbar.

Wenn ich auf das aktuelle PHP 7.2.21 stelle mit dem inoffiziellen Update geht die Seite. Aber meine Skripte ja leider nicht mehr.

Was kann das sein?

Im Anhang die phpinfo mit PHP 5.3.18 als Link. Kann soviele JPG nicht anheften. PDF geht leider ja nicht.
https://drive.google.com/drive/folder...sp=sharing

Grüße Dominik

Zusammengefügt am 14. August 2019 um 21:41:53:
Jetzt hab ich PHP 7.0.33 und anderen auch hinbekommen.

Kann es sein, weil PHP 5.3 nur FastCGI macht?

Aber dann hätte es ja früher auch nicht gehen dürfen.
Bearbeitet von speedfire am 14.08.2019 um 21:41
 
Systemweb
Bei dir ist offenbar nicht in jeder PHP-Version auch das php-mysql Modul mitinstalliert. Jede PHP Umgebung benötigt ein eigenes Modul für die entspr. Version.
 
Springe ins Forum: