Thread Verfasser: Maggan22
Thread ID: 1678
Thread Info
Es gibt 3 Beiträge zu diesem Thema, und es wurde 67 Mal angesehen.
 Thema drucken
installation läuft nicht durch Bleibt bei Schritt 4 hängen
Maggan22
Hallo zusammen,

ich würde gern auf bplaced.net fusion 7.02.05 installieren. doch die installation bleibt bei schritt 4 hängen und wirft eine Fehlermeldung raus:
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /users/schnaeppchen/www/setup.php:214 Stack trace: #0 {main} thrown in /users/schnaeppchen/www/setup.php on line 214

könnte mir jemand weiterhelfen bitte?

Vielen herzlichen Dank vorab schonmal
 
Systemweb
Die letzte offiziell veröffentlichte 7er Version von PHP-Fusion ist die 7.02.07
In dieser wurden damals vor allem 2 gravierende Sicherheitslücken geschlossen, die in vorherigen Versionen wie deiner 7.02.05 noch nicht behoben sind. Es ist daher überhaupt nicht anzuraten, diese alte Version überhaupt noch einzusetzen.

Nun ist aber die Version 7.02.07 ebenfalls bereits in die Jahre gekommen. Zu seiner Zeit war die Programmiersprache PHP noch in Version 5.3 aktuell. Inzwischen sind wir aber bei PHP 7.3 (in Kürze 7.4 angekommen). Mit jeder neuen PHP-Version kamen neue Änderungen, mitunter wurden früher gültige Befehle komplett gestrichen oder Programmierstandards geändert.
In Folge läuft das originale PHP-Fusion 7.02.07 nicht mehr unter aktuellen Serverkonfigurationen ab PHP Version 5.6

Du solltest also besser eine aktuellere Version von Fusion verwenden, entweder die aktuelle Version 9.03 (fehlerlastig und es gibt kaum vernünftige Addons/Infusionen dafür) oder du lädst dir hier aus dem Downloadbereich die sogenannte Inoffizielle DE Version. Inoffiziell deshalb, weil diese nicht von den Original-Entwicklern stammt, aber im Prinzip ist es die 7.02.07 in überarbeiteter Form, so dass alle veralteten PHP-Befehle durch neue Standards ersetzt wurden.

Anschließend musst du nur sicherstellen, dass die von dir gewünschten Infusionen (Addons) ebenfalls aktualisiert sind und unter PHP-Version ab 5.6 lauffähig.
 
Maggan22
Vielen Dank, jetzt hat es geklappt *freu*
 
Springe ins Forum: