Thread Verfasser: Abrafax75
Thread ID: 1776
Thread Info
Es gibt 5 Beiträge zu diesem Thema, und es wurde 676 Mal angesehen.
 Thema drucken
Bugs in der 9.03.110
Abrafax75
Hallo zusammen,

1.) bei der 9er funktioniert die Rechtevergabe bei Neuinstallationen von Infusionen nicht richtig. Der Seiteninhaber bekommt die Rechte nicht eingetragen (bei verschiedenen Infusionen, z.B. Systemweb-Sendeplan und eigene Infusionen), kann sie nur direkt über die Datenbank hinzufügen

2.) Einbindung Locales funktioniert auch nicht richtig. Mit der Anweisung "$locale = fusion_get_locale..." wird immer nur die English.php geladen, obwohl die deutschen Locales da sind. Eingabe der Adresse in der Adressleiste findet die Datei aber. Und wenn man mit "require_ONCE" die Datei ein 2. Mal aufruft, ist im 1. Panel alles weg.

Meine Seite ist auf "Deutsch" eingestellt, keine MLT aktiviert. Gibt es zu den Bugs schon Lösungen?
 
Systemweb
Prüfe mal die jeweiligen Inhalte der infusion.php aller deiner vorhandenen Infusionen.
Die Arrays hatten in Fusion v7 noch feste Nummern zugeteilt, in v9 darf man das nicht machen.
Inkorrekt:
$inf_newtable[1] = ....;
$inf_newtable[2] = ....;
Korrekt:
$inf_newtable[] = ....;
$inf_newtable[] = ....;
Das gilt für alle dort verwendeten Arrays, also auch für $inf_insertdbrow[], $inf_droptable[], $inf_adminpanel[] usw.
 
Abrafax75
Vielen Dank für den Tipp. Im Nivo-Slider waren noch Ziffern drin. Hab die raus gemacht, Fehler bleibt aber trotzdem nach Deinstall => Install
 
Systemweb
Im Prinzip kannst du im Bereich, wo du die Infusionen installierst, nachprüfen ob bei jeder Infusion in der Spalte Adminrecht etwas steht. Fehlt der Eintrag auch nur bei einer einzigen Infusion kann das die Installation jeder anderen Infusion negativ beeinflussen.
Bei jeder Infusion mit fehlendem Eintrag solltest du die enthaltene infusion.php überprüfen.
Genauso bin ich vorgegangen beim gleichen Problem wie deinem und konnte es lösen.
 
Abrafax75
FEHLER GEFUNDEN.

Zu Punkt 1:
Habe heute eine meiner Infusionen etwas überarbeitet und erweitert und bin dabei auf etwas gestoßen. In der Github-Blanko-Infusion von der englischen Supportseite, auf die ich meine Infusion aufgebaut habe, sind einige Fehler drin. Teilweise wurde Code auskommentiert, der eigentlich aktiv bleiben muss (bspw. MLT), und weiters fehlen wichtige Bestandteile komplett. Zum Beispiel ist die $mlt_adminpanel[$language] Routine gar nicht enthalten - wegen eben dieser fehlenden Routine wurde bei mir die Infusion nicht komplett installiert.

Am besten, man vergleicht bestehende und funktionierende Infusionen mit der Blanko-Infusion und fügt die fehlenden Zeilen in der infusion.php ein. Die auskommentierten Zeilen dann noch reaktivieren und schon funzt es nach der Anpassung der infusionsspezifischen Variablen.

Zu Punkt 2:

Wenn man auf einer Seite bspw. "infusionx_panel.php" anzeigen lässt und gleichzeitig die "infusionx.php" aufruft, wobei beide Dateien die selbe Locale-Datei einbinden, funzt es nicht (egal, ob mit include(), require() oder require_once()).
Lösung: Die Datei "infusionx_panel.php" inkludiert die "German.php", die Datei "infusionx.php" bindet bspw. die "German2.php" ein. Mag nicht die schönste Lösung sein, aber so funktioniert's.
Bearbeitet von Abrafax75 am 13.11.2021 um 20:13
https://www.krelli.de
Mods, Hacks und Infusionen für PHP-Fusion v9
 
Springe ins Forum: