Thread Verfasser: Nadowo
Thread ID: 107
Thread Info
Es gibt 34 Beiträge zu diesem Thema, und es wurde 13411 Mal angesehen.

 Thema drucken
Neue Version mit alten Inhalten?
Nadowo
Hallo, ich möchte gerne meine alte Version (v7.01.06) auf eine neue Upgraten (v7.02.07), aber die Inhalte doch gerne behalten.
Wir kann ich das am besten machen?

LG
Nadowo
 
Patrick
Mit Inhalten meinst du

Forenbeiträge, Themen, Seiten, Links, News etc..


Oder ist hir die Rede von den

Infusion, Panels und Mods.

Wenn es sich um das erste Handelt ist es einfach.
Du must dir die Update datei(e)n Runter Laden.
Und so wie es in der Readme steht vorgehen.
Und schon ist es vollbracht.

Das Update Packet auf die neue Version findest du dort
http://phpfusion-deutschland.de/downl...er_41.html

Beim 2teren wird es schon etwas schwerer.
Da zwar einige Infusionen und Mods auch auf auf der enuen Version funktionieren, aber nicht alle.
Es könnte alss durch aus sein das du einige Infusionen und Mods nicht mehr nutzen kannst. Und sie eventuell anpassen must.
Selfmade Is Not Easy Wink
 
Dat Tunes
Wichtig beim Updaten ist zu beachten, da du die zwischen Version 7.01.07,7.02.00, 7.02.01 usw auch runterlädst und Version zu Version Updaten tust, da es sonst zu Fehler und Problemen kommen kann.

Wichtig auch, vorher ein komplettes Backup machen.
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 
Nadowo
Vielen Dank für eure Antworten, eigentlich geht es mir in erster Linie um die Seiten, die Infusionen und Mods sind da erst mal nicht ganz so wichtig.

Gruß
Nadowo

Zusammengefügt am 06. Januar 2014 um 15:41:!31:
Zitat: Dat Tunes schrieb:

Wichtig beim Updaten ist zu beachten, da du die zwischen Version 7.01.07,7.02.00, 7.02.01 usw auch runterlädst und Version zu Version Updaten tust, da es sonst zu Fehler und Problemen kommen kann.

Wichtig auch, vorher ein komplettes Backup machen.


Mal ne ganz doofe Frage, wo bekomme ich die ganzen Upgrates her? Hier finde ich sie leider nicht mehr.

Gruß
Nadowo
Bearbeitet von Nadowo am 06.01.2014 um 15:41
 
Patrick
Hab dir mal eine Seite rausgesucht von vielen Smile

http://php-fusion.at/content/coredown...nloads.php

Hier noch eine
http://phpfusion-4you.de/downloads.ph...age_id=288
Selfmade Is Not Easy Wink
 
Nadowo
So, nun habe ich auf einer Seite von mir sämtliche Upgrates gemacht und bekomme als Dank, ne Latte von Fehlermeldungen in der Log Datei und ausloggen kann ich mich auch nicht mehr.

Was hab ich denn nun für ein Mist gemacht?
 
John Doe
Ich unterstelle Dir jetzt mal, dass Du Dich nicht strikt und genau an die Update-Anleitungen gehalten hast. Vor Allem beim Sprung von V7.01.xx zu V7.02.xx gibt es nicht nur einige Datenbankstrukturen die geändert/ergänzt wurden, sondern es sind auch neue Dateien hinzugekommen und in einigen wurde was geändert oder ergänzt.

Es ist bei Updates existenziell wichtig, sich genau an die Anleitung zu halten!
 
Nadowo
Also ich bin von:

7.01.06 auf 7.02.00
von 7.02.00 auf 7.02.01
von 7.02.01 auf 7.02.02-03
von 7.02.02-03 auf 7.02.04
von 7.02.04 auf 7.02.05
von 7.02.05 auf 7.02.06
von 7.02.06 auf 7.02.07

Fertig, weiß nicht was ich da falsch gemacht haben soll.

Und dies ist die Fehlerlog:

Zitat: Fehler Datum Status
cookie_control/cookie_control_settings.php
Undefined index: ecdp_077 Zeile: 114 06. Januar 2014
cookie_control/cookie_control_admin.php
Undefined index: ecdp_073 Zeile: 38 06. Januar 2014
cookie_control/cookie_control_admin.php
Undefined index: ecdp_073 Zeile: 39 06. Januar 2014
cookie_control/cookie_control_admin.php
Undefined index: ecdp_072 Zeile: 42 06. Januar 2014
cookie_control/cookie_control_admin.php
Undefined index: ecdp_070 Zeile: 48 06. Januar 2014
administration/infusions.php
include() [<a href='function.include'>function.include</a>]: Unable to access ../infusions/fm_userguestbook/infusion.php Zeile: 188 06. Januar 2014
cookie_control/infusion.php
Undefined index: ecdp_076 Zeile: 81 06. Januar 2014
cookie_control/infusion.php
Undefined index: ecdp_075 Zeile: 71 06. Januar 2014
cookie_control/infusion.php
Undefined index: ecdp_074 Zeile: 77 06. Januar 2014
minis/maincore.php
require_once() [<a href='function.require-once'>function.require-once</a>]: Unable to access ../includes/classes/Authenticate.class.php Zeile: 178 06. Januar 2014
minis/maincore.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 209 06. Januar 2014
facebook_likebox_panel/facebook_likebox_panel.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 32 06. Januar 2014
minis/maincore.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 207 06. Januar 2014
facebook_likebox_panel/facebook_likebox_panel.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 30 06. Januar 2014
enhanced_online_users_panel/enhanced_online_users_panel.php
Use of undefined constant DB_SHOUTBOX - assumed 'DB_SHOUTBOX' Zeile: 70 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 26 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 25 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 24 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 23

Bearbeitet von Nadowo am 06.01.2014 um 18:29
 
madison
Also wenn du jetzt mit dem Update bei der letzten Version 7.02.07 angekommen ist, wäre es doch mal einen Versuch wert, vorrausgesetzt das die Datenbank auch richtig aktualisiert wurde, das du einfach nochmal die komplette Version 7.02.07 Core über Ftp hochlädst. Einfach mal versuchen. Smile
 
Nadowo
@ madison, hat leider auch nichts gebracht, es sind zwar weniger Fehlermeldungen aber immernoch welche:

Zitat: minis/maincore.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 190 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 26 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 25 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 23 06. Januar 2014
classes/Authenticate.class.php
Use of undefined constant COOKIE_PREFIX - assumed 'COOKIE_PREFIX' Zeile: 24
 
madison
Ich glaube wärend des Updateverlauf bekommt man zwischen irgendwelchen Versionen, eine neue COOKIE_PREFIX angezeigt. Diese neue COOKIE PREFIX muß man dann in die config.php eintragen. Ich kann mich irren, aber wurde dir so etwas ähnliches nicht auch angezeigt?
 
Nadowo
Ich weiß es leider nicht mehr, ich mache gerade wieder alles Rückgängig, denn so hat es keinen Zweck.

Ich danke dir dir für deine Bemühungen.
 
madison
Würde ich nicht machen, weil die angegebenen Fehlermeldungen nur die COOKIE_PREFIX betreffen, das kann man auch bestimmt anders lösen. Warte doch noch etwas.
 
Nadowo
Zu Spät, hier haben laufend Leute rein geguckt aber keiner hat bisher was gesagt, außer mich für Blond hinstellen.
Ich meine schon, klar bin ich Blond, wenn ich keine Hilfe bräuchte, würde ich hier nicht posten.

Ich bin nur froh das ich es nicht an meiner Hauptseite versucht habe.
 
Dat Tunes
Ist in deiner config.php ein Coolie Prefix eingetragen ?
Die letzten beiden Zeilen sollten sowas beinhalten, einmal den Datenbank Prefix und einmal den Cookie Prefix.

Code 

define("DB_PREFIX", "fusionXYZ_");
define("COOKIE_PREFIX", "fusionXYZ_");



XYZ habe ich einfach nun eingetragen.

Wenn der Prefix nicht vorhanden ist, dann trägst du diesen nach.
Du kannst auch mal schauen, welcher Prefix bei dir genutzt wird.
Bei Firefox einfach mal auf "Extras > Einstellungen" dann auf den Reiter "Datenschutz" und dort nach einzelne Cookies klicken.

Dort suchst du nach der Domain deiner Webseite, kann sein das Du dies selber machen musst, in dem du die Liste durchscrollst.
Dort sollte ein Cookie zu finden dann sein, der wie folgt aussieht:

Code 

fusionXYZ_visited



Was dann vor _visited steht, trägst du beim Cookie Prefix ein.

Sollte evtl. dann dein Problem lösen.

Evtl. bevor du das jetzt versuchst, einfach mal die Cookies für deine Webseite löschen und dann neu einloggen, kann das Problem schon lösen.
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 
Nadowo
Danke Dat Tunes, ich versuche es gerade mit einer anderen Webseite, wenn es dort geht sollte es eigentlich überall gehen.

Hoffe ich mal. Wink
 
madison
Ach nun wein doch nicht gleich Wink
Wenn du es jetzt nochmal versuchst, beachte das du nach irgendeinem Update nachdem du im Adminbereich auf Upgrade geklickt hast, eine Meldung erhälst. Die kopierst du dir am besten und fügst diese neue COOKIE_PREFIX in die config.php auf deinem Server ein und speicherst diese ab und lädst die config.php wieder über Ftp auf deinen Server hoch. Danach sollte alles funktionieren.
 
Nadowo
Oki Madison, werde ich machen. Danke. Ich sagg dann wieder Bescheid ob es gefunzt hat, kann sich nur um Stunden handeln Wink

Ich glaub ich werde mir ein anderes CMS suchen. Klappt das eine, geht das andere nicht, das hat man dann davon wenn man alles macht was das Ding einen sagt und wenn man es nicht macht, wird man als Blöd hingestellt.

Nein Danke. 7 Stunden vergebliche Fummelein reichen.
Bearbeitet von Nadowo am 06.01.2014 um 22:14
 
Sina
hier muss einer echt noch mit Fusion lernen umzugehen hast du dir mal eine readme durch gelesen wie alles geht. Man braucht keine 7 stunden das geht alles in 10 minuten auf die 7.02.07 zu updaten wenn man eine ganz alte version hat.
https://www.youtube.com/watch?v=uT-hB...T-hBZXTwEI

Ein Themes Freak erstellerin (lernerin).
 
Dat Tunes
Was hast du nun genau gemacht ?
Hast du alle Version nach und nach geupdatet ?

Normal ist es so, das wenn man ein Update macht, das es danach keine Probleme gibt, ausnahmen gibt es aber immer wieder mal und du hast leider mal das Glück.

Nicht gleich immer den Kopf in den Sand stecken, den Fehler können passieren und wenn Du nun das CMS wechseln möchtes, sind deine kompletten Inhalte auch weg.

Dann mach heute eine Pause, beschäftige dich mit was anderen und morgen ist auch ein neuer Tag, evtl. kommt dann die Lösung sogar von selbst.

Wir haben auch alle mal angefangen und irgendwie und irgendwas mal gehabt, haben alle aber immer weiter gemacht und aus Fehlern gelernt, den Fusion ist ein klasse System, auch wenn die Technologie teilweise veraltet ist, aber dafür kann man an diesen System noch sehr viel selber machen ohne viel wissen, was man bei anderen Systemen nicht kann.
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 

Springe ins Forum: