Thread Verfasser: Jackler
Thread ID: 1219
Thread Info
Es gibt 10 Beiträge zu diesem Thema, und es wurde 3799 Mal angesehen.
 Thema drucken
Installations Fehler
Jackler
Hallo
Ich habe Php Fusion schon einige male installiert ist aber ein paar Jahre her. Nun wollte ich mal wieder eine Website ins leben rufen.

Bei der Installation gibt es aber bei Schritt 3 also die Datenbank Angaben diesen Fehler:

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /www/htdocs/w01594d0/mgv-mardorf.de/setup.php:214 Stack trace: #0 {main} thrown in /www/htdocs/w01594d0/mgv-mardorf.de/setup.php on line 214

Habe die Datenbank bei meinem Hoster angelegt und die Daten bei der installation angebeben.

Datenbank Host bleibt ja localhost oder?
Datenbank Benutzername und Datenbank Name sind in der regel das selbe oder?

Kann mir jemand weiterhelfen?
 
Rolly8-HL
Hier stellt sich die Frage welche PHP Version hast Du auf Deinem Server eingestellt.
Ab PHP v 7.x musst Du den Fix der Fusion benutzen.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Jackler
Ahh super hat geklappt. Danke für die schnelle Hilfe!

Zusammengefügt am 08. Februar 2017 um 09:44:00:
Die Installation hat gut geklappt.
Habe die Gästebuch Infusion Installiert dort kommt aber unter Infusion also nach der Installation im Admin menü folgender Fehler:

Fatal error: Uncaught Error: Call to undefined function mysql_query() in /www/htdocs/w01594d0/mgv-mardorf.de/infusions/guest_book/admin/gb_update.php:24 Stack trace: #0 /www/htdocs/w01594d0/mgv-mardorf.de/infusions/guest_book/admin/gb_admin.php(113): require_once() #1 {main} thrown in /www/htdocs/w01594d0/mgv-mardorf.de/infusions/guest_book/admin/gb_update.php on line 24

Muss ich bei Infusionen auch irgendeinen Fix benutzen?
Bearbeitet von Jackler am 08.02.2017 um 09:44
 
Rolly8-HL
Zitat: Muss ich bei Infusionen auch irgendeinen Fix benutzen?

Ja musst Du, die meisten alten Infusion sind nicht auf PHP v.7.x ausgelegt.
Es kann ein mysqli_ helfen in manchen Fällen.
Bis v7.0 ab v.7.1x sieht es schon mal wieder anders aus.
Am besten mit PDO arbeiten.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Jackler
mysqli?? PDO? Shock
oder ist es ratsam die seite mit einer älteren version zu erstellen wo noch alles funktioniert?
 
Rolly8-HL
Kannst Du sehen wie Du willst.
Aber es wird Dir auf die Dauer nichts bringen da einige Server schon dabei sind ältere PHP Versionen ab zu schalten da bringt Dir ein zurücksetzen nichts.
Nicht um sonst setzt die V9 auf PDO und auch alle Ratschläge aus der Szene gehen dahin genauso wie andere CMS auch.

Ich kenne eine Stabile Version der PHP-Fusion auf der Basis V7.2.7 mit PDO und PHP v.7.1x fähig von Harlekin Power.
Die älteren Infusion um schreiben bleibt nicht aus, da kann auch die V9 nichts ändern da es um die PHP geht.

Habe sie selbst getestet und benutze diese als Grundlage für meine eigene P-Fusion Nobody.

Also auf kurz oder mittel Fristig auf alte Varianten zurück stellen sollte gehen auf lange Sicht gesehen nicht dann ist eines Tages wenn der Server nicht mehr die nötigen PHP Versionen anbietet aus und nichts geht mehr, ab da musst Du Dich ohnehin mit der neuen Technik beschäftigen.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Jackler
Hab beim server PHP version 5.6 Eingestellt jetzt geht alles.

Tja ist die frage wann die alte PHP version abgeschalltet wird wenn das noch ein paar Jahre dauert ist bis dahin Php Fusion v9 vielleicht ja mal fertig...

Wird denn überhaut noch an v9 gearbeitet?
 
Rolly8-HL
Das abschalten wird wohl schneller gehen wie Dir lieb ist.
In dieser Richtung ist schon von der V7.3 und auch die V8 die Rede, also warum sollten die Server das alte noch weiter anbieten.
Einige Seitenbetreiber habe dazu schon ihre Informationen bekommen.

Ja an der V9 wird weiter gearbeitet, mit der 5. RC Generation ist aber auch nicht alles 100 pro.
Dazu kommt noch das die UK`s ihren eigenen Hoster aufgezogen haben den man mieten kann.
Was mich zur nächsten Frage bringt, die V9 ausgereift wird man dort nutzen können, ist sie aber auch so für alle verfügbar? Infusion werden angeboten aber werden auch diese so frei verfügbar sein?
Es scheint das sich dieses zu einem Wirtschaftsmodel entwickelt.

Da ich weder mich dort ein mieten werde noch auf diese Steine bauen werde, bin ich dabei mein eigenes Ding in dieser Richtung zu machen.
Alternative mit Fix war nur der Anfang und mit der V7.3 DE ist auch nicht zu rechnen.
Bearbeitet von Rolly8-HL am 09.02.2017 um 10:56
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Jackler
Würde euch bzw dich ja gerne unterstützen aber da ich nicht so fit im Programmieren bin bringts denn was wenn ich Geld Spende?
 
Rolly8-HL
Nein es bringt nichts weder das eine noch das andere (bei mir).
Als Alternative in dieser Richtung kann ich Dir diese Seite anbieten.
http://harlekinpower.de
Wir beide habe diese Alternative Version der Fusion schon auf PHPv7.1x getestet und werden es auch weiter entwickeln sobald etwas nicht gehen sollte.

Die eine oder andere Infusion wurde schon angepasst und auf Anfrage werden die einen oder anderen Tipp`s möglich sein.
Bearbeitet von Rolly8-HL am 09.02.2017 um 11:30
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Springe ins Forum: