Thread Verfasser: TBR
Thread ID: 1326
Thread Info
Es gibt 4 Beiträge zu diesem Thema, und es wurde 1663 Mal angesehen.
 Thema drucken
Forum verursacht Fehlermeldung
TBR
Hallo zusammen,

wenn ich einen Beitrag im Forum verfasse oder bearbeite, werden folgende Fehler angezeigt:


Fehler:   preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead   Zeile:   21
Datei:   includes/bbcodes/mail_bbcode_include.php

$text = preg_replace('#\[mail=([\r\n]*)([^\s\'\";:\+]*?)\](.*?)([\r\n]*)\[/mail\]#sie', "hide_email('\\2').''", $text);


Fehler:   preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead   Zeile:   20
Datei:   includes/bbcodes/mail_bbcode_include.php
$text = preg_replace('#\[mail\]([\r\n]*)([^\s\'\";:\+]*?)([\r\n]*)\[/mail\]#sie', "hide_email('\\2').''", $text);



Fehler:   preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead   Zeile:   22
Datei:   includes/bbcodes/url_bbcode_include.php
$text = preg_replace('#\[url\]([\r\n]*)([^\s\'\"]*?)([\r\n]*)\[/url\]#sie', "'<a href=\'http://\\2\' target=\'_blank\'
    title=\'\\2\'>'.trimlink('\\2', 20).(strlen('\\2')>30?substr('\\2', strlen('\\2')-10, strlen('\\2')):'').'</a>'", $text);


Ich nutze PHP Fusion 7.02.07, die deutsche version von dieser Seite hier.
Scheinbar sind die bbcodes veraltet, oder so. Gibt es dazu irgendein Update?

Habe jetzt schon des öfteren Fehlermeldungen durch die bbcodes gehabt (z.B. durch Infusion)
Information:
PHP Version: Nicht ausgewählt •  MySQL Version: Nicht ausgewählt •  PHP-Fusion: Nicht ausgewählt
 
John Doe
Nimm die entsprechenden BB-Codes aus dem V7 MySQLi Paket, die sollten gehen.
Information:
PHP Version: Nicht ausgewählt •  MySQL Version: Nicht ausgewählt •  PHP-Fusion: Nicht ausgewählt
 
TBR
Kann ich den entsprechenden Ordner einfach überschreiben oder sollte ich da anders vorgehen?
Information:
PHP Version: Nicht ausgewählt •  MySQL Version: Nicht ausgewählt •  PHP-Fusion: Nicht ausgewählt
 
Krelli
Mach vorher ein Backup der BB-Codes und probiers aus Wink

Sollte aber eigentlich funktionieren. Ersetze aber auch die zugehörigen locales im locales Ordner, da einige Übersetzungen angepasst bzw erweitert wurden.
Information:
PHP Version: 8.2.x •  MySQL Version: Nicht ausgewählt •  PHP-Fusion: IPv9-DE-MOD
 
Springe ins Forum: