Thread Verfasser: Andydeluxe97
Thread ID: 1493
Thread Info
Es gibt 9 Beiträge zu diesem Thema, und es wurde 1266 Mal angesehen.
 Thema drucken
Inoffizielle DE
Andydeluxe97
Hallo Zusammen,

Ich hab mir das CMS installiert und möchte die Deluxe Drop down menu als Navi einbauen.

Den code raus:

Code 

echo "<div class='sub-header clearfix floatfix'>".showsublinks("","")."</div>\n";



Den Code Rein:

Code 

echo "<table cellspacing='0' cellpadding='0' border='0' style='padding-top: 3px;' width='auto' align='center'>\n<tr>\n
<td align='left'>\n";
include INFUSIONS."deluxe_dropdown_menu/menu.php";
echo "</td>\n</tr>\n
</table>\n";



Gespeichert & Hochgeladen, Dann kam dieser Fehler.

Fehlerstatus:

Code 

Error: Table 'ni313204_2sql1.fusionLg83p_menus' doesn't exist Fatal error: Call to a member function fetch_assoc() on boolean in /var/customers/webs/ni313204_2/includes/db_handlers/mysqli_functions_include.php on line 95 



Liebe Grüße Andydeluxe97
 
Systemweb
Die Infusion war nicht korrekt installiert, d.h. die Tabelle(n) für das Drop Down Menü sind in der DB nicht vorhanden.
 
Andydeluxe97
Hallo Systemweb,

ich hab mal in der infusions.php rein geschaut, es sag komisch aus. Wo ich das letzte mal runtergeladen habe war es voll inordnung.

Keine ahnung was jetzt mit der Drop Down Menu passiert ist

Gruss Andydeluxe97
 
Layzee
Ach Mensch Leute... bitte....

...auch diese "Infusion" gehört nicht nur ins Anitquariat sondern ist darüber hinaus auch "leicht" vebuggt, hoffnungslos veraltet (wurde seinerzeit für die V7.00 und 7.01 geschrieben) und ausserdem unaussprechlich hässlich.
Oder um es kürzer auszudrücken: Nicht mehr zeitgemäss. Alleine der Tabellenaufbau löst in mir nur noch Ka**reiz aus.

Es gibt im Web unzählige kostenfreie anständige (und responsive) Dropdown-Menüs in allen möglichen Formen.
Einfach mal umschauen und endlich mal diese veralteten "Code-Kompromisse"entsorgen!
 
Andydeluxe97
Hallo,

Na naja, ich fande es aber besser nach meiner meinung halt. Aber es muss ja jeder selber wissen, Versteh mich nicht falsch, ist aber s

Gruss Andydeluxe97
 
ckoneman04
Ohne Worte !
 
Andydeluxe97
Ohne Worte! Theard Close!
 
Layzee
@Andy:
Es geht hierbei nicht so sehr um den "persönlichen Geschmack" sondern vielmehr um veraltete Technik, die auf modernen Serverumgebungen zum Einsatz kommt.
Das ist nicht allein eine Frage der Kompatibilität sondern auch und vor Allem eine Frage der Sicherheit.
Die Serverumgebungen werden ja auch nicht aus reinem Spass weiterentwickelt. Viele Updates enthalten unter Anderem das Schliessen bekanntgewordener Sicherheitslücken.
Veraltete Scripte/Addons/Infusionen/Panels berücksichtigen diese neuen Sicherheitsrichtlinien nicht, da sie zum Zeitpunkt der Entwicklung noch gar kein Thema waren.

Da ist es dann auch sehr oft nicht mit dem Auswechseln von "TYPE=..." zu "ENGINE=...." in der infusion.php getan.

Davon abgesehen muss es doch (zumindest nach meinem Verständnis) auch im Interesse jedes Webseitenbetreibers sein, seine Webseite mit aktueller (und sicherer) Technik zu betreiben, nicht nur aus optischen Gründen.
 
Andydeluxe97
Ja gut, stimmt auch wieder alles
 
Springe ins Forum: