Thread Verfasser: mkasl
Thread ID: 1790
Thread Info
Es gibt 5 Beiträge zu diesem Thema, und es wurde 185 Mal angesehen.
 Thema drucken
Inoffizielles Benutzeranmeldung
mkasl
Noch eine Frage - habe alles installiert : Nun wollte ich eine Benutzer- Registrierung testen . Eigenes PW - Benutzername : Insider und Registrierungsmail . Fehlermeldung : Registrierung fehlgeschlagen
Registrierung fehlgeschlagen aus folgenden Grund/Gründen:

Die Aktivierungs E-Mail konnte nicht versendet werden.
Bitte kontaktiere den Seiten Administrator.
Bitte versuche es nochmals.
Sprich - der neue Benutzer wurde nicht aktiviert . Frage geht das nicht im eigenen Netzwerk . habe das früher immer so gemacht . VG
Nach dem Admin Login konnte ich einen neuen Benutzer einrichten . Vorher als z.b. Fremder nicht möglich . test ... http://mkasl.synology.me/fusion/news.php
Bearbeitet von mkasl am 29.07.2021 um 17:23
 
Systemweb
Wenn eMail-Bestätigung für neue Registrierungen aktiviert ist, wird der neue User zuerst in eine temporäre Datenbank-Tabelle abgelegt. Erst nach Klick auf den Bestätigungslink in der Mail wird der Benutzer in die Tabelle der registrierten Benutzer verschoben.
Im Script wird vor dem Speichern in der temp. Tabelle die Mail generiert und versendet. Ist kein Mailversand möglich, wird der Vorgang mit der von dir zitierten Fehlermeldung abgebrochen.
Legst du hingegen einen neuen Benutzer als Admin selbst an, ist der sofort registriert und muss keine Bestätigungsmail erhalten.
Darum klappte bei dir das manuelle Anlegen im Adminbereich, aber nicht die "normale" Registrierung auf der HP.

Wenn dein Mailversand fehlschlägt hat das folgende Ursachen.
Entweder ist dein Server ein Windows-Server, der den "sendmail" Befehl nicht kennt (den gibts nämlich nur in der Linuxwelt) und du hast keinen authentifizierten Mailversand (SMTP) in Administration > Einstellungen > Sonstige definiert oder die SMTP Daten sind fehlerhaft.
Wenn du einen Linux-basierten Server hast ist das Postsystem nicht installiert bzw. nicht richtig konfiguriert.
Da du aber mit einem Homeserver arbeitest, höchstwahrscheinlich dynamische IP hast und dein Server eine lokale IP-Adresse aus dem Heimnetzwerk benutzt, solltest du in jedem Fall mit einem externen Mailserver arbeiten, um nicht nur den Versand in den Griff zu bekommen, sondern vor allem auch um sicherzustellen, dass die Mail beim Empfänger ankommt.
Alle Mailserver nutzem Filtermethoden für eingehende Mails, um Spam zu reduzieren. Da wird u.a. geprüft, ob die IP zum angegebenen Hostnamen auflöst und umgekehrt, ob die IP in Blacklists steht, Microsoft Server vertrauen nur bekannten Absender-IPs, die sie bereits kennen und in der Vergangenheit nicht negativ aufgefallen sind usw.
Daher ist die einfachste Lösung, einfach z.b. die Daten eines Freemail-Kontos von GMX, Web.de o.ä. für den authenthifizierten Mailversand zu benutzen.
 
mkasl
Guten Morgen . Mein Server von Synology - DS 218 / NAS ) ist ein Linuxserver . Emailversand ist dort aktiviert . Es läuft alles über gmx.net ( free ) bzw. web.de .Auch in php inofff Fusion sind diese Optionen aktiviert . Ich muss auch nicht als Admin erst bestätigen . Ich arbeite ja schon jahrelang mit diesem NAS System und hatte beginnend mit pimped hier alle fusionen am Laufen . Allerdings mit ähnlichen Problemen - der Mailbenachrichtigung . Aber neue User konnten sich immer erfolgreich registrieren . Auch Passwort vergessen lief wie gewollt . Ich habe die Registrierung von außen durch eine andere Person testen lassen . Nachricht - er hat sich erfolgreich registriert - kommt aber nicht mit seinen Daten als Mitglied auf die Seite . Verständlich weil er keine Aktivierungsmail bekam - genau wie bei meinem Selbsttest . Wer ist schuld daran ? php inoff Fusion . ; gmx , web.de oder Servereinstellungen . ich habe keinen Rat wo ich ansetzen kann .
 
Systemweb
Hast du mal versucht, eine Mail direkt über die Shell zu senden? Möglicherweise erhältst du Fehlermeldungen die dir weiterhelfen.
Code
echo "Subject: sendmail test" | sendmail -v my@email.com
 
mkasl
Über Win +R wird der befehl : echo "Subject: sendmail test" | sendmail -mkasl@gmx.de nicht ausgeführt - Muss aber zugeben , dass ich dies noch nie gemacht habe

Zusammengefügt am 31. Juli 2021 um 09:28:22:
Guten Morgen - ich habe jetzt auf meinem Linux / Synology NAS Server die Emailbenachrichtigung geändert - somit funktioniert nun die Registrierung von Außen - Auch Passwort vergessen usw . Ich bedanke mich für die Hilfe . Allerdings funktionieren einige Optionen noch nicht . Z.B. Download . Dazu mache ich ein neues Thema und hoffe auch dort auf Tipps und Unterstützung . Schönes Wochenende Manfred
Bearbeitet von mkasl am 31.07.2021 um 09:28
 
Springe ins Forum: