Thread Verfasser: darkmasspriest
Thread ID: 393
Thread Info
Es gibt 9 Beiträge zu diesem Thema, und es wurde 6138 Mal angesehen.
 Thema drucken
Hilfe bei der Installation
darkmasspriest
Guten Morgen Liebe User.
Ich stehe vor einem ähnlichen Problem wie mancher hier.
Ich betreibe seit ca. 1 Jahr nun Win 2008 Server.
Da ich mich immer über meinen privaten(freund) "Provider" geärgert habe über seine Paranoiden einstellungen und dementsprechenden Serverabsicherung (z.b. 3 verschiedene verschlüsselungsprogs jede festplatte verschlüsselt-NSA könnte ja gucken) so habe ich mich nun entschieden einen eigenen IIS-Server aufzusetzen und selbst zu hosten. Nun habe ich erfolgreich wordpress, joomla und meine eigene auf HTML basierende Webseite am Laufen, auch aus dem Internet erfolgreich erreichbar. Jedoch macht mir php-fusion nun schwierigkeiten.
Bei "Step2", der Installation, so verlangt php-fusion auf diverse Ordner (ich denk bekannt) schreibrechte. Ich habe bereits 2 Tage mit googlen verbracht(noch eine woche und ich mach google nen hochzeitsantragDickeslachen), samt einem IIS-reset auf werkseinstelllung und alles wieder von Vorne... selbst wenn ich dem IUSER vollzugriff gebe, so bleibt das problem bestehen. Da das ein Windows server ist brauche ich das Thema chmod777 nicht anschneiden, da das NTFS System dies ja nicht kennt. Also ebenso FTP (da ja win-serv.) und ich ja selbst hoste.
Nun suche ich eine lösung, jemand der mit Win2k8-r2+iss server arbeitet und erfahrung mit dem system + php-fusion hat.
Da ich bei google kein spanisch& portugisisch beherrsche, so muss ich auf viele hilfeseiten verzichten samt youtube-videos(alles was ich nicht kenne kommt mir spanisch vor Wink )
Xamp,apatche,wie auch janaserver kommen mir nicht drauf& würden sich denk ich parrallel mit dem iis serv auch beissen da ja nur ein Port 80 benutzen kann.
Wenn mir jemand helfen kann, bezüglich der schreibrechtevergabe wäre mir das angenehm und wäre sehr dankbar. nochmal erwähnt - ich hoste selbst, bin mein eigener Provider -entweder ich bekomms zum laufen oder halt net, aber wäre mir lieber als später eine offizielle seite in altem html, da bei html ja auch nicht viel möglich ist.
Ich bedanke mich schon mal herzlich.
Liebe grüße Darkmasspriest
Bearbeitet von darkmasspriest am 30.01.2015 um 01:54
 
Janilein
Tja da du Support für Joomla suchst würde es sicher mehr Sinn machen, wenn du in einem Joomla-Forum suchen würdest.
Hier wird normalerweise das CMS PHP-Fusion Supportet.
 
darkmasspriest
Sorry hatte mich im text vertan,hatte statt php fusion joomla geschreiben, da ich beim text schreiben abgelenkt wurde. hab das nun korrigiert. Joomla läuft aber ich möcht halt php fusion zum laufen bekommen. danke für die hilfe wenn ich welche bekommen kann
 
Dat Tunes
NSA am morgen vertreibt Kummer und sorgen Dickeslachen *Ironie*

Vorab, wenn die NSA was lesen will, dann macht die dass auch, da kannst du verschlüsseln wie Du willst. Die behörde kann sogut wie alles entschlüsseln, was zur Zeit auf dem Markt ist. Da kann es nur helfen, wenn dir selber eine Verschlüsselung schreibst.

Aber nun zum Problem:
IIS habe ich damals auch mal testweise genutzt und ganz ehrlich, des taugt nicht wirklich viel was.
Du muss erstmal einen Webserver einrichten und dannach kannst Du auch einen FTP User einrichten via Filezilla oder ähnlichen. Diese kann ansich dann auch die CHMOD rechte ändern. Wie es in den neuen Versionen ist, weiss ich nicht.

Hilfreich kann aber das hier sein: http://blogs.technet.com/b/bernhard_f...erver.aspx

Ansonsten einfach im IIS Forum mal melden, die können dir dort sicherlich am einfachsten Helfen, den hier hat sicherlich keiner dieses System.

PS: Wenn du wirklich einen Sicheren Server haben willst, nutze kein Windows sondern Linux, diese sind 10x Sicherer und von der Verschlüsselung auch viel weiter als Windows. Und so schwer ist die Eingabeaufforderung auch nicht.
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 
John Doe
Kurz zum Verständnis:
BEIDE (Server-)Systeme haben ihre Vor- und Nachteile.
Linuxserver als "sicherer" zu bezeichnen halte ich grundlegend für falsch denn am Ende kommt es immer auf den Admin an, wie sicher ein Server wirklich ist - und zwar egal mit welchem OS.

Windows-Server haben den (grossen) Vorteil, dass hier viel mehr mit der Maus gearbeitet werden kann als bei Linux. So ist die Dateirechte-Vergabe bei Windows-Servern im Grunde viel einfacher als serverseitig bei Linux:

1. Navigiere mit dem Dateiexplorer zu der Datei (Ordner) deren Rechte Du ändern möchtest.

2. Klicke mit der rechten Maustaste auf die Datei (Ordner) und wähle aus dem Kontextmenü den Eintrag "Eigenschaften".

3. Wähle den Karteireiter "Sicherheit".

4. Markiere im Bereich "Gruppen- und Benutzernamen" das Internet Gastaccount-Konto.

5. Aktiviere im Bereich "Berechtigungen für Benutzer" die Checkbox für "Scheiben".

-FERTIG-
Dieses Mitglied wurde gelöscht!
 
darkmasspriest
Danke erst mal für die Antworten. Also wenn es so weiter geht probier ich doch mal linux in einer virtuellen maschine aus.
Bezüglich des Datei-Explorers mit den Eigenschaften, dem Internet Gastkonto (nennt sich hier IUSER) die Rechte geben - geht - bis nach dem Schliessen des Eigenschaft-Fensters, dann ist alles wie vorher... Egal ob über den IIS Server oder Explorer ich kann die Schreibrechte nicht so ändern das es funktioniert.Ich bin auf dem System natürlich Administrator, also wäre das nicht das problem von den Berechtigungen, jedoch kommt ich bis jetzt nciht weiter. vielleicht seh ich ja mal den wald vor lauter bäumen nicht kann auch sein... ist meist so... auf das simpelste kommt man nciht wenn estwas hoch-kompliziert ist. ich schaue auch mal in dem empfohlenen teamspeak rein. Wenn jemand noch idee´n hat, immer her damit ich bin für alles offen.
Lg Darkmasspriest
 
John Doe
Standardmässig gibt es im IIS zwei "default" Benutzergruppen... IUSR (und nicht IUSER) und IIS_IUSRS. Du musst der Benutzergruppe IUSR die entsprechenden Rechte geben, dann sollte es funktionieren.
Dieses Mitglied wurde gelöscht!
 
darkmasspriest
Danke für den Hinweis des IUSR. Erfolgreich dank der Hilfe von euch - gelöst! bin nun einige schritte weiter. Super! Erstmal herzlichen Dank!
Ps:Bin nun abends ab und zu in eurem empfohlenen Teamspeak.
Lg Darkmasspriest
 
John Doe
Freut mich wenns jetzt geklappt hat Smile
Willkommen in der Community Smile
Dieses Mitglied wurde gelöscht!
 
Springe ins Forum: