Thread Verfasser: mkasl
Thread ID: 623
Thread Info
Es gibt 32 Beiträge zu diesem Thema, und es wurde 8350 Mal angesehen.  Ausserdem wurden Dateien angehängt.

 Thema drucken
Fusion setup
mkasl
Kann das Setup aufrufen - alles grün - keine Fehler - nur auf die Datenbank zum Einrichten BenName admin ( weiß nicht ob das richtig ist und wo er festgelegt wird. Ein Passwort habe ich auch eingetragen . Wird beides nicht akzeptiert ( rot untersetzt.)
Wo kann ich diese beiden Optionen neu einrichten ? Mein Webserver ist die Synology Diskstation.
Ich weiß - es muß funktionieren , weil ich frusion dort schon mal drauf hatte.
VG
 
Rolly8-HL
Hast Du vorher dafür auch eine Datenbank angelte?
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
mkasl
Hallo
Ich hatte wordpress und Pimped auf meiner Station.Es muß irgend etwas schief gelaufen sein - deshalb habe ich die Datenbank deinstalliert und danach wieder installiert.Nun beim neuen Einrichten von Fusion wird der Zugang nicht mehr akzeptiert.Da eh alles neu ist , hätte ich gerne neu Ben.Name und Passwort vergeben-weiß aber nicht wie
VG Manfred
mkasl hat folgende Datei angehängt:
Du hast nicht die Berechtigung die Anhäge dieses Themas zu sehen.

Bearbeitet von mkasl am 26.08.2015 um 19:38
 
Rolly8-HL
Erst ein mal musst Du auf Deinem Server eine Datenbank anlegen den Namen kannst Du frei wählen und ein Passwort.
Danach Setup und dies Daten dann dort eintragen, Die Datenbank wird nicht von alleine angelegt nur mit Daten gefüllt deswegen hast Du auch kein Zugriff weil es keine Gibt oder Du Falsche Daten da eingetragen hast.
Zitat: Datenbank deinstalliert und danach wieder installiert

Dann hast Du wohl keine die musst Du da erst wieder neu anlegen.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
mkasl
Auf meiner Diskstation / sprich mein Server gibt es phpMyAddmin .Die hatte ich mal deinstalliert und nun neu installiert.Läuft auch - aber ich wurde jetzt nach keinem BN und PW gefragt,Ist mir auch unbegreiflich.Das erste Bild ,wenn ich zugreifen will und das zweite die Eingerichtete Datenbank.Irgend was übersehe ich.Ich kenne das von einem anderen Server - da mußte man bei Fusion Setup -urs_ oder usr weiß nicht genau eintragen
mkasl hat folgende Datei angehängt:
Du hast nicht die Berechtigung die Anhäge dieses Themas zu sehen.
 
Rolly8-HL
Kenne ich anders sieht aber so aus das Du da ein PW vergeben musst ansonsten in dem Teil eine DB mit frei gewählten Namen anlegen.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
John Doe
Wenn phpMyAdmin auf einem Server installiert ist und läuft, heisst das nicht, dass auch eine oder mehrere Datenbanken ANGELEGT sind.
phpMyAdmin ist im Grunde nur die grafische Adminoberfläche für Datenbanken. Hierüber muss zunächst eine NEUE Datenbank angelegt werden. Ob solch eine Datenbank in deinem System dann das Synonym "usr_" bekommt, liegt entweder an dir selbst oder es wird vom jeweiligen System so vorgegeben.

Neben der Datenbank selbst muss auch ein entsprechender User angelegt werden, der Schreib- und Leserechte für die betreffende Datenbank hat.
Ich kenne jetzt so aus dem Stehgreif das von dir beschriebene System nicht, aber ich bin mir ziemlich sicher, dass man hierüber im Internet entsprechende Anleitungen oder Tutorials findet.
Dieses Mitglied wurde gelöscht!
 
mkasl
Ein Grundsatzfrage : Mir ist klar,dass ich für die Datenbank mal ein Passwort erstellt habe .Das muß ja in irgend einer Datei stehen und kontrollierbar sein.Nur wenn ich die Datenbank lösche ist doch wohl das PW auch weg.Oder sehe ich das falsch ? Warum werde ich nach einer Neuinstall der phpmyadmin nicht wieder nach Eintrag eines BN und PW gefragt.Ich glaube hier sollte man den Fehler suchen.

Zusammengefügt am 28. August 2015 um 11:00:22:
OK -vielleicht war diese Frage etwas blöd gestellt-will mal berichten was sich bis dahin getan hat und hoffe,dass die Experten hier mir weiterhelfen können.Habe die Inhalte in einen Ordner / FTP hochgeladen- alle Berechtigungen waren schon auf 777. Habe http://192.168..../fusion/setup.php aufgerufen.Alles grüne Haken.Habe dann die Datenbank erstellen können: localhost BN :admin PW....DB Name: DS115 und weiter unten nichts verändert.Ging weiter zu Schritt 4 : Konfiguration und Datenbank erstellen -und nun warte ich eine halbe Stunde , dass es weiter zu Schritt 5 geht - nichts tut sich - PC ist nicht eingefrohren. Kaspersky hatte ich deaktiviert.
Bin am Verzweifeln und der Aufgabe sehr nahe
VG Manfred
Bearbeitet von mkasl am 28.08.2015 um 11:02
 
Rolly8-HL
Hast Du mal nachgesehen ob in der phpMyAddmin die von Dir angegebene DB DS115 dort vorhanden ist?
So lange er keine Verbindung zur DB aufbauen kann geht er auch nicht weiter, ab da ist erst ein mal Schluss.

Nachtrag: Wo willst Du das denn eigentlich machen auf Deinem PC oder auf einem externen Server?
Bearbeitet von Rolly8-HL am 28.08.2015 um 17:22
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
mkasl
Find da nichts.Ich kenne das von anderen Servern.!. auf die Seite des Servers gehen
2.Fusion Inhalt auf den Server per z.B. FileZilla hochladen / alles auf 777
3. http://mein_server/ Fusionsverzeichnis/setup.php So lief das alles locker ab.
Auf meiner Station gibt es die Datenbank ( MariaDB ) wenn man die installiert (ohne,dass BN oder PW abgefragt wird , installiert sich gleichzeitig die phpmyadmin .
Rufe ich nun über den Browser die setup.php auf , wird BN und Passwort verlangt was ich nie festgelegt hatte
komisch ja . das irritiert mich.
 
Rolly8-HL
Die MariaDB kenne ich nicht wenn Du kein Pw vergeben hast kannst Du mal Global mit "admin" "password" zum anmelden versuchen.

Meinst Du jetzt diese Setup?
http://lapaloma-blanca.de/lapalomafus.../setup.php
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Septron
Hallo,

MariaDB hat kein standart pw es muss eins von Beginn an festgelegt werden ich nutze selber MariaDB für meine TS3 Server (MySQL wird ja nicht mehr für diesen zweck Supportet).

lg Septron
Rechtschreibfehler und Fehlende Satzzeichen sind eine Sünde meiner
Gedanklichen Tastatur wer alle findet darf sie behalten.
Domain Owner of: SGI Fusion | PHPFusion-SupportClub | PHPFusion Germany
 
mkasl
Hallo - auf Vorschlag / super , mache ich hier weiter. Eigentlich wird ja kein Passwort benötigt / nur BeName : root .Habe aber zu BenName root ein PW vergeben .Vorher noch eine Frage - neuerdings gibt es ja Maria DB 10 - dort wird automatisch auch WordPress installiert .Ich habe im Paket Maria 5 und 10 installiert , kann ich Beide nutzen oder beeinflussen sie sich , denn bis jetzt habe ich den selben Fehler bei Schtitt 4 / Konfiguration und Datenbank erstellen / geht dort nicht weiter .

Zusammengefügt am 04. März 2018 um 18:16:58:
Siehe #3 genau so mit anderem PW . Ich glaube hier ist der Fehler - weiß aber nicht was ich da bei der DS115 ändern soll /
mpkasl.lima-city.de/hinweise/images/db10.jpg


Zusammengefügt am 05. März 2018 um 11:!39:29:
Hallo
Ich weiß nicht mehr , was ich alles noch ändern kann ? PHP Fusion läßt sich einfach auf meiner DS115 nicht installieren . WordPress ohne Probleme - also muß die maria DB10 OK sein.
Ich bin am Ende und gebe auf zumal ich es auf anderen Servern ohne Probleme installiert habe.
Danke für Eure Mühe
Manfred

Zusammengefügt am 07. März 2018 um 17:28:58:
Zitat: Rolly8-HL schrieb:

Hast Du mal nachgesehen ob in der phpMyAddmin die von Dir angegebene DB DS115 dort vorhanden ist?
So lange er keine Verbindung zur DB aufbauen kann geht er auch nicht weiter, ab da ist erst ein mal Schluss.

Nachtrag: Wo willst Du das denn eigentlich machen auf Deinem PC oder auf einem externen Server?

Da gibt es ja sooo viele Dateien - wo sollte der Name stehen ich finde ihn nicht
VG
Bearbeitet von mkasl am 07.03.2018 um 17:28
 
Rolly8-HL
Den Beitrag kannst Du jetzt nicht mehr zitieren. Die Zeiten haben sich geändert.
Um da etwas genaues zu zu sagen bräuchte man eine ungehinderten Zugang zu Deinem Server um einiges zu testen und auslesen zu lassen.
Denn nicht nur mit der PHP 7 hat sich da vieles geändert sondern der Rest auch.
Mache da gerade meine Erfahrungen mit MySQL Server Version 5.7.19 und die sind nicht ohne.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Systemweb
MariaDB ist 100% kompatibel zu MySQL.

Hast du denn für Fusion vorher eine Datenbank erstellt? Andere Systeme unterstützen teilweise das Neuanlegen einer noch nicht vorhandenen Datenbank beim Durchführen des Setups, bei PHP-Fusion muss die Datenbank bereits existieren.
auf deinem Screen habe ich keine solche DB gesehen, oder soll die Installation bei DS115 oder anderswo hinein?

Edit:
Wenn es die Datenbank DS115 sein soll: wie hast du diese Datenbank angelegt? Eventuell liegt hier ein Rechteproblem vor.
Bearbeitet von Systemweb am 08.03.2018 um 00:45
 
mkasl
Zitat: Systemweb schrieb:

MariaDB ist 100% kompatibel zu MySQL.

Hast du denn für Fusion vorher eine Datenbank erstellt? Andere Systeme unterstützen teilweise das Neuanlegen einer noch nicht vorhandenen Datenbank beim Durchführen des Setups, bei PHP-Fusion muss die Datenbank bereits existieren.
auf deinem Screen habe ich keine solche DB gesehen, oder soll die Installation bei DS115 oder anderswo hinein?

Edit:
Wenn es die Datenbank DS115 sein soll: wie hast du diese Datenbank angelegt? Eventuell liegt hier ein Rechteproblem vor.
Ich danke dir - bin mir keines Fehlers bewußt - aber an irgend einer Konfig. muß es ja liegen - Ich habe das schon viele Male alles neu gemacht und - wie hier zu lesen ist - meistens mit Erfolg . Einige Male wollte das Setup mit DB einrichten auch nicht weiter laufen.
Ich habe jetzt eine formatierte HDD eingebaut und lasse dem Synology Assistant seine Arbeit machen - Werde nur die MariaDB 10 und mysqlAdmin installieren - eine Datenbank mit Namen MKDB einrichten -PHP Fusion 7.02.7 vorbereiten und hochladen ( Frage welche PHP - habe 5.6 und 7 ) wenn das Setup dann an der bewußten Stelle wieder soppt , mache ich einige Screen davon .
Bis dann - freue mich über jede Hilfe , denn ich bin durch die vielen Versuche sehr verwirrt . Z.B. , dass nach dem Einrichten der DB immer kommt : keine Tabellen - die kommen doch erst durch das Setup - oder ?
VG

Zusammengefügt am 08. März 2018 um 12:!37:00:
Sorry / neues Thema , weil ich hier keine jpg hochladen konnte - Problem - kein CMOD nicht ändern - Alle Dateien haben 777 als Vorgabe 7 Fehler weil zurücksetzen z.B. auf 755 nicht möglich ist

Zusammengefügt am 08. März 2018 um 13:51:10:
Setup meldet jetzt : Schritt 4: Konfiguration und Datenbank erstellen
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /volume1/web/fusion/setup.php:214 Stack trace: #0 {main} thrown in /volume1/web/fusion/setup.php on line 214

Zusammengefügt am 08. März 2018 um 16:19:!39:
Hi
Ich denke mal es liegt an der Konfiguration der DS115/web Das Zusammenspiel der Apache Versionen 2,2 oger 2,4 mit den PHP 5.6 oder 7.0
Welche Einstellungen will php Fusion 7.02.7 ?
Bearbeitet von mkasl am 08.03.2018 um 16:19
 
Systemweb
Du versuchst die originale PHP-Fusion 7.02.07 zu installieren, hast aber PHP 5.6 bzw 7.0 auf dem Server, deshalb funktioniert es nicht.
Installiere besser das Update aus dem DL Bereich von hier.
 
mkasl
Zitat: Systemweb schrieb:

Du versuchst die originale PHP-Fusion 7.02.07 zu installieren, hast aber PHP 5.6 bzw 7.0 auf dem Server, deshalb funktioniert es nicht.
Installiere besser das Update aus dem DL Bereich von hier.

OK wie meinst du das mit PHP 7 und 5.6 soll ich da was deinstallieren und welchen Apache soll ich nehmen ? Das Update _online ist doch viel kleiner - ist das OK oder meinst du was Anderes
Ich habe noch nie einUpdate machen müssen . In der Updateversion ist doch kein setup und kein install . Außerdem ist ja die Fullversion nur hochgeladen aber konnte nicht installiert werden.
Oder muß man in die Full noch die Update rein laden ?
0 Ahnung

Zusammengefügt am 09. März 2018 um 09:08:10:
Zitat: Systemweb schrieb:

Du versuchst die originale PHP-Fusion 7.02.07 zu installieren, hast aber PHP 5.6 bzw 7.0 auf dem Server, deshalb funktioniert es nicht.
Installiere besser das Update aus dem DL Bereich von hier.

OK ich habe das versucht - laut Anweisung - auch die config.php wollte ich erweitern- diese ist aber leer - logo - Fusion-full hatte ja auch kein Setup akzeptiert . Als Ergebnis - nichts hatte sich geändert.
Nach den vielen Fehlversuchen frage ich mich bekümmert , ob man nicht mehr klar sieht.
Ich mache das auf meiner Synology DS115 schon jahrelang / ab und zu wollte die Inst / setup auch nicht weiter laufen . Aber diese alle Möglichkeiten mußte ich nie ausschöpfen :
PHP Fusion hochgeladen , Rechte gesetzt _config umbenannt und fertig. Meine Diskstation habe ich auch nur das empfohlene installiert und alles lief gut .
Damals gab es noch keine MariaDB10 im Angebot - lief alles über 5 / Meine Frage und Vermutung : liegt es vielleicht an Synology-Updates und nicht an php Fusion ?
Bearbeitet von mkasl am 09.03.2018 um 09:08
 
Systemweb
Also noch mal Schritt für Schritt.

An deinem Apache usw. solltest du gar nichts verstellen, updaten oder sonstwas.

Du sagst auf deiner DS115 steht dir PHP 5.6 sowie 7.0 zur Verfügung. Da das originale PHP-Fusion 7.02.07 nur bis PHP 5.4 einwandfrei läuft, ab 5.5 mit Einschränkungen und ab 5.6 bereits überhaupt nicht mehr, kannst du es auch nicht installieren.
Die von dir zitierte Fehlermeldung "call to undefined function mysql_connect" zeigt, dass du aber genau das erfolglos versucht hast.
Das hier im Downloadbereich erhältliche sogenannte "Inoffizielle Updatepack" nutzt nämlich diesen Aufruf der Funktion "mysql_connect" nicht, daher ist klar dass du das falsche Paket versuchst zu installieren.

Nun lösche einfach mal den ganzen Fusion-Kram von deiner DS115 runter. Fange neu an indem du das neue Pack gemäß der enthaltenen Anleitung installierst.
Vor einer Neuinstallation von PHP-Fusion (auch bei dem Updatepack) muss man immer die im Hauptordner enthaltene Datei "_config.php" (die natürlich erstmal noch komplett leer ist) umbenennen in "config.php".
Dann ruft man das Setup auf.

Wenn du laut Anleitung einfach ALLES aus dem Ordner "full" auf die DS115 kopiert hast funktioniert garantiert auch die Installation, vorausgesetzt deine Datenbank-Daten sind richtig.

Da du sogar WordPress testweise installieren konntest muss PHP-Fusion ebenfalls laufen. Aber wie gesagt nur dann, wenn du nicht das veraltete Installpaket nimmst oder irgendwas miteinander vermischst weil du die Anleitung im Updatepaket scheinbar nicht richtig gelesen hast.
Dort steht klar dass du bei Neuinstallation den kompletten Inhalt des Ordners "full" hoch lädst.
Der Update-Ordner ist wie beschrieben nur für bereits vorhandene Fusion - Homepages zu verwenden.
Bearbeitet von Systemweb am 09.03.2018 um 18:22
 
mkasl
Hi
Danke für deine Hinweise - noch ist keine Gartenzeit - also PC / Wionterhobby. Eine Frage - hast du schon mal mit dem Synology Server der Diskstation gearbeitet.Dann muß ich nicht ausschweifen ,denn dort läuft einiges anders als z.B. Lima-City...Bei der Install der Station muß ich auf alle Fälle / web installieren und auch einrichten und aktivieren. Da wird Apache 2.2 oder 2.4 sowie PHP 5.6 und 7 benötigt.Ohne dem gibt es kein Verzeichnis / web wo man php Fusion hochladen kann.
Also nicht berühren geht nicht . Um sicher zu sein , dass es nicht an php Fusion liegt , habe ich die Pimped 7.00.6 , andere wie 7.2.6 und eben die von dir erwähnte aus DE / 7.02.07 versucht . Auch unterschiedliche Datenbanken in Maria DB 5 und 10 - einzeln und parallel eingerichtet . Nur Maria DB 5 alleine geht nicht mehr , weil MYphpAdmin automatisch Maria DB 10 mit installiert . Habe alles mit und ohne PW - nur beN. : root versucht .
Fazit : bei allen Versuchen blieb das Setup bei Punkt 4 Konf. und Datenbank einrichten hängen. Habe auch schon während des Setup s mein Kaspersky Intern . Secr. deaktiviert .... und alles auch auf einem 2. Win10 Rechner ohne Erfolg probiert. Deshalb meine Aussage - bin genervt und weiß nicht weiter .
Jetzt hast du vielleicht einen Ansatzpunkt.
Ich danke dir und warte auf Hilfe
VG Manfred
 

Springe ins Forum: