Thread Verfasser: Abracadaver
Thread ID: 676
Thread Info
Es gibt 3 Beiträge zu diesem Thema, und es wurde 2024 Mal angesehen.
 Thema drucken
[Gelöst] Startseite öffnet nicht automatisch / 403 Forbidden
Abracadaver
Hallo und im Vorfeld direkt ein dickes Dankeschön an alle Mitglieder hier, welche sich die Mühe machen kompetent zu Problemlösungen beizutragen.
Und ebenfalls Danke für das wirklich gute Anfänger-Tutorial, welches mir in den letzten Tagen extrem viel geholfen hat.

Bevor ich zum eigentlichen Problem komme, möchte ich kurz erläutern wie weit mein Wissensstand ist und welche grundlegenden Einstellungen ich bereits vorgenommen habe.

Vor einigen Tagen habe ich mir einen Level 4 Webspace bei Hetzner angemietet, da ich unserem Gaming-Clan gerne eine Webpräsenz bieten möchte und ich mich im Vorfeld bereits über PHP Fusion informiert habe und mehr als begeistert bin.

Installation und Einstellungen wurden laut Tutorial vorgenommen und die Seite läuft auch in den Grundzügen Problemlos.

Das erste Problem war, dass ich meine Seite nicht über die eigentliche URL erreichen konnte, da die Domain-Namen http://zz-multigaming.de/ und http://www.zz-multigaming.de/ in den ersten Stunden noch nicht erreichbar waren und ich darum als Site-URL die vorläufige URL http://zz-multigaming.de.www364.your-server.de/ angab. Auch die vorläufige URL war allerdings nur erreichbar, wenn ich per Browser direkt auf index.php, news.php oder dergleichen zugreife.

Das Problem mit der falschen URL habe ich bereits behoben, indem ich siteurl und site_hoste direkt in der SQL-Datenbank abgeändert habe. Auch das Problem welches viele haben, dass Sie bei Zugriff über eine bestimmte URL nach einloggen auf der Seite direkt wieder ausgeloggt wurden, wurde dadurch behoben.

Mein Problem besteht nun darin, dass bei Zugriff auf die Seite über z.B. zz-multigaming.de nicht automatisch auf die news.php, welche als Startseite angegeben ist zugegriffen wird.

Stattdessen bekomme ich folgende Fehlermeldung:
Forbidden

You don't have permission to access / on this server.
Apache Server at zz-multigaming.de Port 80

Durch Eingabe der URL zz-multigaming.de/news.php kann ich auf die Seite zugreifen. Aber es ist ja eher unschön, wenn die Nutzer der Seite den Pfad zur Startseite noch selbst eingeben müssen.

Die Fehlermeldung macht dahingehend Sinn, da ich den Verzeichnisindex vor direktem Zugriff gesperrt habe. Aber dadurch, dass news.php als Startseite in der Datenbank hinterlegt ist, sollte es doch eigentlich klappen oder sehe ich das falsch?

Das Root-Verzeichnis der Webseite ist automatisch als Ordner public_html angegeben.
Also /public_html/

Dadurch bleibt der site_path meines Erachtens nach bei /.


Mein Wissen und meine Erfahrung bezüglich PHP Fusion bzw. PHP im Allgemeinen sind sehr begrenzt, da ich komplett am Anfang stehe und mich Stück für Stück einarbeite.
Die Syntax ist in Teilen verständlich, allerdings wird es einige Zeit dauern bis ich soweit durchgeblickt habe um mir selbst zu helfen.

Ich denke es handelt sich hier um einen einfachen Anfängerfehler und ich hoffe, dass mir jemand aus diesem Forum eine kleine Stütze bieten kann um dieses Problem zu lösen.

Falls noch Informationen gebraucht werden, schaue ich gerne, was ich euch geben kann.

Vielen Dank schon mal im Vorraus und einen schönen Freitag.

MFG, Abracadaver
Bearbeitet von Abracadaver am 06.11.2015 um 16:03
 
Rolly8-HL
Zitat: da ich den Verzeichnisindex vor direktem Zugriff gesperrt habe.

Kann ich mir nicht vorstellen das es Sinn macht, wenn Du Deine URL mit zz-multigaming.de angibst darf die index.php nicht gesperrt werden denn in der steht
Zitat: redirect($settings['opening_page']);

Und opening_page bedeutet welche PHP geöffnet werden soll bei Dir jetzt news.php und wenn mann auf diese eine Notwendige index.php nicht zugreifen kann wirst Du auch nicht weitergeleitet zu Deiner Startseite news.php.

So gut wie alle anderen index.php Dateien im System sind leer wenn Du da hin verwiesen wirst hast Du eine leere Seite.

Also den Verzeichnisindex nicht sperren dann sollte es gehen.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
Abracadaver
Vielen Dank Rolly8-HL für die Antwort.

Da ich wirklich ganz am Anfang stehe, fällt es mir schwer mein Anliegen ansprechend zu formulieren, da mir Fachbegriffe und Kenntnisse fehlen. Aber ich denke du hast mein Problem im Ansatz verstanden.

Ich bekomme über meinen Anbieter Hetzner die Möglichkeit den Verzeichnisindex zu deaktivieren, damit bei Eingabe der URL und keiner festgelegten Startseite nicht der Index of / angezeigt wird.

Ich habe ein wenig mit den Funktionen "gespielt" und dabei fiel mir auf, dass in der Web-Konsole von Hetzner keine Startseite angegeben ist.
Mir war nicht bewusst, dass ich die Startseite dort noch einmal festlegen muss, da diese in den Grundeinstellungen von PHP Fusion schon angegeben ist. Und plötzlich funktioniert es trotz deaktiviertem Verzeichnisindex.

Im Endeffekt, wie ich schon vermutet hatte, war es einfach ein dummer Anfängerfehler. Ich habe gestern das Web durchforstet auf der Suche nach einer Problemlösung, englische Seiten gewälzt usw. und kam nicht auf die Idee, die naheliegendste Lösung zu versuchen.

Ich danke dir für deine Mühe und entschuldige mich, dass ich aufgrund eines so einfach Fehlers Gott und die Welt verrückt mache.

MFG, Abracadaver
 
Springe ins Forum: