Thread Verfasser: DJ Vampire
Thread ID: 820
Thread Info
Es gibt 7 Beiträge zu diesem Thema, und es wurde 3199 Mal angesehen.
 Thema drucken
Error 500
DJ Vampire
Ja ich weis. Alles gerade etwas leinhaft, aber gerade am Anfang mit basteln.

Habe mir 2 Datein erstellt. 1mal button.php Inhalt:

Code

<html>
<button style="width:100px;background-repeat:no-repeat;background-position:center center;" onclick="window.open('./kicken.php')" title="SCKick" onfocus="blur()">Streamkick</button>
</html>


2. Datei Kicken.php (Port und PW unkenntlich gemacht)
Code
<?php
$server="serv-2.sm4y.de";
$port="****";
$password="*******";

$fp = fsockopen($server, $port, &$errnum, &$errstr, 2);
if($fp){
   fwrite($fp, "GET /admin.cgi?pass=$password&mode=kicksrc HTTP/1.0\r\nUser-Agent:Mozilla/4.0\r\n\r\n");
}

echo "Streams Have Been Kicked!!!";

?>


Wenn ich den Button drücke bekomme ich nen Error 500. Kann mir wer sagen warum?
 
SuNflOw
Huhu,

genau kann ich es auch nicht sagen aber wenn du aus deiber Kicken.php die folgenden Zeilen auskommentierst:
Code
$fp = fsockopen($server, $port, &$errnum, &$errstr, 2);
if($fp){
   fwrite($fp, "GET /admin.cgi?pass=$password&mode=kicksrc HTTP/1.0\r\nUser-Agent:Mozilla/4.0\r\n\r\n");
}

verschwindet dann der Fehler?
Wenn ja liegt der Fehler dort und dann müsste man nochmal genau schauen. Vielleicht ist "fsockopen" vom Hoster deaktiviert. Vielleicht kannst du dann CURL nutzen.

lg,
SuN
________________________________________________
I got my swim trunks and my Flippie-Floppies *-*
 
DJ Vampire
Ich habe heute nochmal von vorne angefangen. Jetzt geht es. Kp an was es lag. Aber danke dir.
 
motripfl
hab da ne frage ich habe nach langen überlegt mal wieder mit php-fusion zu arbeiten habs installiert alles super und nach fertig stellung kam http error 500 was hat das zu bedeuten?

mfg
 
Rolly8-HL
Das etwas nicht angezeigt werden kann weil es nicht abrufbar ist oder nicht vorhanden.

Zitat: ich habe nach langen überlegt mal wieder mit php-fusion zu arbeiten

Es hat sich viel geändert, mehr Info wäre besser.
1. Wenn Dein Server auf PHP v.7.xx steht PHP Version 5.3.x - 7.0.x FIX (inoffiziel) benutzen.
Gruß Rolly8-HL
Was für Andere Wichtig ist muss für mich nicht genauso Wichtig sein!
Bin Dickkopf Unbelehrbar mache aus Protest nicht das was andere für Richtig halten!
Das gibt einem zu Denken oder?
 
motripfl
ich habe mein server umstellen lassen auf 5.6 aber ich kriege die 9ner version immer noch nicht installiert. immer noch http error 500.

fir 7.02 läuft aber die meisten themes laufen da nicht.

mfg morten

Zusammengefügt am 22. Februar 2017 um 16:13:26:
nehme alles zurück hat grade alles geklappt und ich hab jetzt nur ein problem das ist auf englisch und wenn auf sprache ändern gehe steht nur englisch drinne Sad
Bearbeitet von motripfl am 22.02.2017 um 16:13
 
John Doe
Dann würde ich mal das deutsche Sprachpaket in deine Seite laden und dann im Adminbereich umstellen.
 
Springe ins Forum: