Thread Verfasser: John Doe
Thread ID: 83
Thread Info
Es gibt 9 Beiträge zu diesem Thema, und es wurde 4571 Mal angesehen.
 Thema drucken
CKEditor
John Doe
Hallo,

bei mir zeigt es immer den CKEditor auf den Eigene Seiten Formular an, egal ob ich TinyMCE "aktiviere" oder "deaktiviere".

Ist das normal und wie könnte ich es am einfachsten lösen?
 
Patrick
Nutzt du die Überarbeitete DE Version von hier ?
Bei mir ist das nicht, wenn ich ihn aus mache ist es aus.

Ich nutze die Überarbeitete DE Version von hier
Selfmade Is Not Easy Wink
 
John Doe
nein ich habe ihn selber per mod eingebaut
 
Dat Tunes
Ob in der DE Version oder per Mod, wir haben auch nur den Mod verwendet und fest eingebunden der Version.

Wenn du es genau nach ReadMe machst, dann klappt es auch . Ggf. mal den CK-Editor updaten.
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 
John Doe
Hallo, ich habe mir den aktuellen von der CKEditor Seite gezogen, damit ist es genau so.

nochmal zum Fehler:
wenn der TinyMCE in den Admineinstellungen -> sonstige Einstellungen aktiviert ist.

Dann wird er natürlich auch im Formular unter Eigene Seiten angezeigt.
Wenn ich aber dann den Button über dem Formular (TinyMCE Aktivieren/Deaktivieren) drücke passiert nichts.

dieser Button hat ein onclick attribut:

Code 

onclick=\"SetTinyMCE(".(!isset($_COOKIE['custom_pages_tinymce']) || $_COOKIE['custom_pages_tinymce'] == 0 ? 1 : 0).");\"



Dieses setzt einen Cookie:

Code 

if (isset($_COOKIE['custom_pages_tinymce']) && $_COOKIE['custom_pages_tinymce'] == 1 && $settings['tinymce_enabled']) {
   echo "<script language='javascript' type='text/javascript'>advanced();</script>\n";
} else {
   require_once INCLUDES."html_buttons_include.php";
}



Soweit ich sehe ist das in der PHPF DE Version nicht verändert?
 
Dat Tunes
Der CKEditor wird über die admin_header.php sowie admin_header_mce eingebunden und in keiner anderen Datei was verändert.

Die Abfrage in den eigenen Seiten ist nur eine Cookie abfrage und hat nichts mit dem CKEditor zu tun.
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 
John Doe
ja das weis ich, aber das löst das Problem nicht...

Ich habe es gemacht wie in der Anleitung und selbst bei einer neuen Installation ist der Fehler vorhanden!

PS: hab das Problem selber gelöst...
Bearbeitet von John Doe am 21.12.2013 um 15:00
 
Dat Tunes
Wo war den der Fehler ?
Poste doch mal deine Lösung für andere User Wink
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht.
Was lernen wir ?
Wir entfernen einfach den Nutzer und das Problem ist gelöst !

Sollte das Problem nicht gelöst sein, WD40! WD40 hilft immer !
 
John Doe
Ich habe in die "header_mce.php" und "header_admin_mce.php" folgendes anstelle der Anleitung geknallt.

Code 


<script type='text/javascript'>
   var ckenable = 0;

   function advanced() {
    ckenable = 1;                 
   }

   $(document).ready(function() {
      if (ckenable == 1){
        $( 'textarea' ).ckeditor();
      }
    });       
</script>



Zur Erklärung:
Auf allen Adminseiten, die den TinyMCE nutzen, wird die JS function advanced() aufgerufen sofern der TinyMCE global aktiviert ist. Mit diesen Änderungen wird nicht nur ein Javascript Error behoben, jetzt funktioniert auch das an und aus schalten des CKEditors wenn man eine "Eigene Seite" erstellen will!
 
Springe ins Forum: